Align and Distribute Issues

Post your questions, comments and suggestions. Ask questions or report problems here.

Align and Distribute Issues

Postby Michael Duckett on Mon Sep 13, 2010 10:49 pm

Start in N scale.
Using second brick pattern from left, create a field 60' high and 102' long.
Using Factory Window 15, the really big one, make 5 windows and distribute them more or less evenly along the wall about 6' from the top. Select all 5 windows and the wall. Click Arrange, click Distribute, select Horizontal, click Preview. Huh. That dont look rite; there all bunched up to the left.
Delete them, select another window at random, this time the dinkey 6 lite 5th from left. Same result.
Ideas?
Michael the Crank
Michael Duckett
 
Posts: 56
Joined: Mon Sep 13, 2010 7:49 pm

Re: Distribute not working properly

Postby evande on Wed Sep 15, 2010 8:55 am

will try the steps you listed in order on our XP here. Attached file would really help!
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby evande on Wed Sep 15, 2010 9:05 am

this is interesting. I tried your steps, worked fine. But then since it was not real easy to see, I changed the paper to landscape and choose zoom 50% (which you did not mention if you did?) at screen 50% the distribute did behave strangely. We will test further. Meantime work-around is use screen zoom 100%
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby evande on Thu Sep 16, 2010 7:34 am

Since you are back, did you try screen zoom 100% distribute on your XP?
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby Michael Duckett on Thu Sep 16, 2010 1:31 pm

Ok, more data. In N scale and Zoom @ 100%, I made a wall, 50' wide and 30' tall. I added 5 of the 3 over 3 industrial windows and distributed them. Worked fine. I aligned them. Worked fine too. The dialog box for Align contains an area that holds a value that the selected objects will be aligned to. Entering a value into this space has NO effect on the outcome. Why allow me to input a value then? I then added 2 of my favorite large windows and the distribute and align worked fine. I added another window and that one went in just peachy. So i saved the file and am emailing it to you.
Next part. In N scale and Zoom @ 100%, I made a wall, 60' wide (Wider than the window) and 30' tall. I added 8 of the 3 over 3 industrial windows and attempted to distributed them. I started selecting them beginning at the right. As i made the 5th selection, all 5 windows zoomed off of the left side of the screen. Kinda odd. So i saved the file and am emailing it to you.
You will know.
Michael the Crank.
Michael Duckett
 
Posts: 56
Joined: Mon Sep 13, 2010 7:49 pm

Re: Distribute not working properly

Postby evande on Thu Sep 16, 2010 4:20 pm

thanks ! Got the files and am studying them based on your very detailed description. Will get back after some study.
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby evande on Thu Sep 16, 2010 7:59 pm

We have fixed align/distribute at screen zoom ratios now. But we want to fix a couple more things before posting the next update. So stick with screen zoom 100% for this operation until the next update.

Regarding align, the number you see in the box is just a feedback indicating what measurement the windows would be using. It is not meant to be editable, just a reference for you. We will lock out the ability to edit the number so as not to cause confusion.

I was able to duplicate the thing you described: grouped items moving to the left. How I did it was this:
1) click on 4 out of 5 items
2) when clicking on the 5th instead of releasing the mouse, I moved the mouse.
3) the initial 4 items moved as you described
to avoid this behavior, mouse up... that is: click and release on each item you wish to group before moving. I will see if there is a way to prevent moving inadvertently.
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby evande on Fri Sep 17, 2010 9:49 am

fixed the accidental non-release of the mouse click causing selected items to move.

Fixed distribute at all screen zoom ratios, and locked out editing of number in align box.

Taking a look again at that file that printed oddly for you in N after re-scaling from O as it is very odd.

We will email you a version all your own to try and break for us ;) check your email later today.
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby evande on Fri Sep 17, 2010 5:49 pm

update has been sent to your email.

And wonder of wonders we figured out why that strange file behaved strangely. Now we can fix. What it ended up being was the 3 blank pages included in the project. We extensively tested multi-page projects but it never occurred to us to add 3 pages and put nothing on them.
See you can break a ball bearing.
Evan Designs
evande
Site Admin
 
Posts: 220
Joined: Tue Sep 02, 2008 8:40 am

Re: Distribute not working properly

Postby Michael Duckett on Sat Sep 18, 2010 5:18 am

I installed the patch. When starting the app i get the following error: Unable to Proceed Error:429 ActiveX component can't create object Occured while Loading the Design Screen

Ok, I'm off to the Train Show! See ya later.

Michael the Crank
Michael Duckett
 
Posts: 56
Joined: Mon Sep 13, 2010 7:49 pm

Next

Return to Feedback & Helpdesk

Who is online

Users browsing this forum: DarcylKar, Endorminnis, Google [Bot], Olivergaw, Rifardjib, SportbettingGar and 3 guests

cron